My SAAB needs repair advice, help!

joulupukki
"Kaasari"
Viestit: 29
Liittynyt: Ma Syys 01, 2008 18:37

My SAAB needs repair advice, help!

Viesti Kirjoittaja joulupukki »

Moro,

I had a little trouble on a long distance drive (2 500 km) with my Saab 900S 2.0 16V.

The radiator started to leak, slowly but unstoppably. Luckily the leakage was so slow that it was enough to refill the cooling liquid in - let's say - every ~300-400 km. The engine temperature was always in the middle of the green zone during the whole distance.

This alone would not have been a serious problem, however the coolant leaked down from the top right corner of the radiator partly to the exhaust pipe (where it's connected to the engine) and also partly to the cables next to the battery in the bottom of the radiator.

Can the coolant cause any damage to the electrical cables/connectors? If yes, what should I do with them? (WD40?)

The reason I suspect that something is wrong there is because since this accident happened the car occasionaly looses the ignition when I drive it at higher speed (above 100). When this happens the "CHECK ENGINE" turns on and the engine goes off. When I restart the car everything seems to be normal.
Sometimes when this happens the engine does not loose the ignition, but it keeps running and the car twiches quite badly. As I mentioned this mostly happens above 100, but rarely even at lower speeds.

I'd really appreciate some advices;

Thanks,

A Saab owner

Ps: The radiator is already fixed by a guy who has repaired radiators in the last 26 years (for 15 EUR).

Avatar
9000CD23T
"Team Ylläpito"
"Team Ylläpito"
Viestit: 6952
Liittynyt: Pe Heinä 02, 2004 12:45
Paikkakunta: ex Jyväskylän MLK
Viesti:

Re: My SAAB needs repair advice, help!

Viesti Kirjoittaja 9000CD23T »

Coolant is not good for electrical appliances, cell to be changed soon.
WD40 is not a solution to dilemma, even if someone else insulation petroleum jelly.
This isolate moisture very well.
Petroleum jelly can be placed in the plug, not for anything else.
Relay housing, circuit boards, NOT THESE

But is not the best option would be to change the cell ..!
These current problems would disappear ..!
900i-5D Combi Coupe-84*/900i-4D Sedan-86*/900i-4D Sedan-88*/9000CD 2.3T-91*/OG9³SE-01
(*=ex) #2060#

mart96
"Viggen"
Viestit: 514
Liittynyt: To Elo 05, 2004 11:39

Re: My SAAB needs repair advice, help!

Viesti Kirjoittaja mart96 »

..your problems with ignition could not be connected with the radiator, but there is a ground point near the radiator-berhaps coolant fluid had some influence. So cehck it and clean those wires and ground point.

joulupukki
"Kaasari"
Viestit: 29
Liittynyt: Ma Syys 01, 2008 18:37

Re: My SAAB needs repair advice, help!

Viesti Kirjoittaja joulupukki »

Hi,

Thanks for the advice. I'll clean those connectors (and buy that petroleum jelly thing you mentioned) and check the ground point.

At the moment the problem still persist even though the radiator and the leakage was fixed and now the cables are dry. Actually it gets worse, now the engine misses quite often even at lower speeds.

Kiitos,

Joulupukki

joulupukki
"Kaasari"
Viestit: 29
Liittynyt: Ma Syys 01, 2008 18:37

Re: My SAAB needs repair advice, help!

Viesti Kirjoittaja joulupukki »

Few days passed after the radiator was fixed and the random ignition problems are now gone...

So I just needed to wait till the cables get dry... 8)

Vastaa Viestiin